re = /^(([^,]*,){2})([^,]*,)(.*)$/m
str = '1,2,3,4,5,6,7'
subst = '\\1\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result