use strict;
my $str = '1,2,3,4,5,6,7';
my $regex = qr/^(([^,]*,){2})([^,]*,)(.*)$/mp;
my $subst = '\\1\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";