$re = '/^(([^,]*,){2})([^,]*,)(.*)$/m';
$str = '1,2,3,4,5,6,7';
$subst = "\1\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;