#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-1]?\d|2[0-3])(?::(?:[0-5]\d?)?)?$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"1:" & @CRLF & _
"1:1" & @CRLF & _
"12" & @CRLF & _
"12:" & @CRLF & _
"12:4" & @CRLF & _
"12:23" & @CRLF & _
"23:5" & @CRLF & _
"23:59" & @CRLF & _
"" & @CRLF & _
"23:9" & @CRLF & _
"24:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")