import re
regex = re.compile(r"^(?:[0-1]?\d|2[0-3])(?::(?:[0-5]\d?)?)?$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"1:\n"
"1:1\n"
"12\n"
"12:\n"
"12:4\n"
"12:23\n"
"23:5\n"
"23:59\n\n"
"23:9\n"
"24:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")