// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-1]?\d|2[0-3])(?::(?:[0-5]\d?)?)?$").unwrap();
let string = "0
1
1:
1:1
12
12:
12:4
12:23
23:5
23:59
23:9
24:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}