using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-1]?\d|2[0-3])(?::(?:[0-5]\d?)?)?$";
string input = @"0
1
1:
1:1
12
12:
12:4
12:23
23:5
23:59
23:9
24:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}