$re = '/^(?:[0-1]?\d|2[0-3])(?::(?:[0-5]\d?)?)?$/m';
$str = '0
1
1:
1:1
12
12:
12:4
12:23
23:5
23:59
23:9
24:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);