import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[a-zA-Z0-9].+)";
final String string = "En estos negocios es importante desarrollar competencias diferenciadoras y superiores que se basen en la orientación a resultados, carácter, habilidades interpersonales, capacidades personales y liderar el cambio.\n"
+ " \n"
+ "<h3>Metodología</h3>\n\n"
+ "Se debe trabajar en las actitudes propias de cada persona que permitan realizar actividades necesarias para estas organizaciones y que requieren un desempeño superior y especializado como los análisis de tendencias, de mercados, de canales de comercialización, de acciones de marketing y de posibilidades de alianzas estratégicas.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}