// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[a-zA-Z0-9].+)").unwrap();
let string = "En estos negocios es importante desarrollar competencias diferenciadoras y superiores que se basen en la orientación a resultados, carácter, habilidades interpersonales, capacidades personales y liderar el cambio.
<h3>Metodología</h3>
Se debe trabajar en las actitudes propias de cada persona que permitan realizar actividades necesarias para estas organizaciones y que requieren un desempeño superior y especializado como los análisis de tendencias, de mercados, de canales de comercialización, de acciones de marketing y de posibilidades de alianzas estratégicas.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}