import re
regex = re.compile(r"(^[a-zA-Z0-9].+)", flags=re.MULTILINE)
test_str = ("En estos negocios es importante desarrollar competencias diferenciadoras y superiores que se basen en la orientación a resultados, carácter, habilidades interpersonales, capacidades personales y liderar el cambio.\n"
" \n"
"<h3>Metodología</h3>\n\n"
"Se debe trabajar en las actitudes propias de cada persona que permitan realizar actividades necesarias para estas organizaciones y que requieren un desempeño superior y especializado como los análisis de tendencias, de mercados, de canales de comercialización, de acciones de marketing y de posibilidades de alianzas estratégicas.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")