const regex = new RegExp('^(<string name=\\"){1}[\\w.]+(\\">){1}[\\w ]+(?i)yoti(</string>){1}', 'gm')
const str = `<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.yoti.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email yoti</string>
<string name="loc.component.help.email.label">Email YoTi</string>
<string name="loc.component.help.email.label">Email YOTI</string>
<string name="loc.component.help.email.label">Email YO.TI</string>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}