import Foundation
let pattern = #"^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.yoti.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email yoti</string>
<string name="loc.component.help.email.label">Email YoTi</string>
<string name="loc.component.help.email.label">Email YOTI</string>
<string name="loc.component.help.email.label">Email YO.TI</string>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)