import re
regex = re.compile(r"^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}", flags=re.MULTILINE)
test_str = ("<string name=\"loc.component.help.email.label\">Email EasyID</string>\n"
"<string name=\"loc.component.help.email.label\">Email EasyID</string>\n\n"
"<string name=\"loc.component.yoti.help.email.label\">Email EasyID</string>\n\n"
"<string name=\"loc.component.help.email.label\">Email yoti</string>\n"
"<string name=\"loc.component.help.email.label\">Email YoTi</string>\n"
"<string name=\"loc.component.help.email.label\">Email YOTI</string>\n\n\n"
"<string name=\"loc.component.help.email.label\">Email YO.TI</string>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")