#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!w{1,3}\.)[\w-]+(?=\.example)"
Local $sString = "https://prefix.example.com" & @CRLF & _
"https://www.prefix.example.com" & @CRLF & _
"https://www.pre-fix.example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"https://www.prefixnow.example.com" & @CRLF & _
"https://www.wonprefix.example.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")