$re = '/(?!w{1,3}\.)[\w-]+(?=\.example)/m';
$str = 'https://prefix.example.com
https://www.prefix.example.com
https://www.pre-fix.example.com
https://www.example.com
https://www.prefixnow.example.com
https://www.wonprefix.example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);