re = /(?!w{1,3}\.)[\w-]+(?=\.example)/m
str = 'https://prefix.example.com
https://www.prefix.example.com
https://www.pre-fix.example.com
https://www.example.com
https://www.prefixnow.example.com
https://www.wonprefix.example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end