import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!w{1,3}\\.)[\\w-]+(?=\\.example)";
final String string = "https://prefix.example.com\n"
+ "https://www.prefix.example.com\n"
+ "https://www.pre-fix.example.com\n"
+ "https://www.example.com\n"
+ "https://www.prefixnow.example.com\n"
+ "https://www.wonprefix.example.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}