#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{1,16}(\/\d{1,6})?"
Local $sString = "COIN" & @CRLF & _
"A/1" & @CRLF & _
"QWERTYUIOPASDFGH/6" & @CRLF & _
"USD/2" & @CRLF & _
"coin" & @CRLF & _
"10" & @CRLF & _
"US_Dollar/100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")