// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{1,16}(\/\d{1,6})?").unwrap();
let string = "COIN
A/1
QWERTYUIOPASDFGH/6
USD/2
coin
10
US_Dollar/100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}