using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{1,16}(\/\d{1,6})?";
string input = @"COIN
A/1
QWERTYUIOPASDFGH/6
USD/2
coin
10
US_Dollar/100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}