import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{1,16}(\\/\\d{1,6})?";
final String string = "COIN\n"
+ "A/1\n"
+ "QWERTYUIOPASDFGH/6\n"
+ "USD/2\n"
+ "coin\n"
+ "10\n"
+ "US_Dollar/100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}