re = /[A-Z]{1,16}(\/\d{1,6})?/m
str = 'COIN
A/1
QWERTYUIOPASDFGH/6
USD/2
coin
10
US_Dollar/100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end