#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)10\.100\.([1-9]\d*|\d{2,})\.([^1]$|\d{2,})"
Local $sString = "10.100.0.11" & @CRLF & _
"" & @CRLF & _
"10.100.1.12" & @CRLF & _
"" & @CRLF & _
"10.100.11.4" & @CRLF & _
"" & @CRLF & _
"10.100.44.1" & @CRLF & _
"" & @CRLF & _
"10.100.10.4" & @CRLF & _
"" & @CRLF & _
"10.100.02.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")