using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"10\.100\.([1-9]\d*|\d{2,})\.([^1]$|\d{2,})";
string input = @"10.100.0.11
10.100.1.12
10.100.11.4
10.100.44.1
10.100.10.4
10.100.02.4";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}