// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)10\.100\.([1-9]\d*|\d{2,})\.([^1]$|\d{2,})").unwrap();
let string = "10.100.0.11
10.100.1.12
10.100.11.4
10.100.44.1
10.100.10.4
10.100.02.4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}