use strict;
my $str = '10.100.0.11
10.100.1.12
10.100.11.4
10.100.44.1
10.100.10.4
10.100.02.4';
my $regex = qr/10\.100\.([1-9]\d*|\d{2,})\.([^1]$|\d{2,})/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}