#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[\[(\w+)]]((?>[^[]+|\[[^[]|(?R))*)\[\[/\1]]"
Local $sString = "Example nested" & @CRLF & _
"" & @CRLF & _
"[[section_abc]]" & @CRLF & _
"<div>" & @CRLF & _
" [foo]bar" & @CRLF & _
" [[section_abc]]baz[[/section_abc]]" & @CRLF & _
"several lines of html ..." & @CRLF & _
"</div>" & @CRLF & _
"[[/section_abc]]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")