using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(\w+)]]((?>[^[]+|\[[^[]|(?R))*)\[\[/\1]]";
string input = @"Example nested
[[section_abc]]
<div>
[foo]bar
[[section_abc]]baz[[/section_abc]]
several lines of html ...
</div>
[[/section_abc]]
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}