import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[(\\w+)]]((?>[^[]+|\\[[^[]|(?R))*)\\[\\[/\\1]]";
final String string = "Example nested\n\n"
+ "[[section_abc]]\n"
+ "<div>\n"
+ " [foo]bar\n"
+ " [[section_abc]]baz[[/section_abc]]\n"
+ "several lines of html ...\n"
+ "</div>\n"
+ "[[/section_abc]]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}