re = /\[\[(\w+)]]((?>[^[]+|\[[^[]|(?R))*)\[\[\/\1]]/
str = 'Example nested
[[section_abc]]
<div>
[foo]bar
[[section_abc]]baz[[/section_abc]]
several lines of html ...
</div>
[[/section_abc]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end