$re = '`\[\[(\w+)]]((?>[^[]+|\[[^[]|(?R))*)\[\[/\1]]`s';
$str = 'Example nested
[[section_abc]]
<div>
[foo]bar
[[section_abc]]baz[[/section_abc]]
several lines of html ...
</div>
[[/section_abc]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);