using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*(?:[A-Za-z].*\d|\d.*[A-Za-z]))[A-Za-z0-9]{10,50}$";
string input = @"foobarasdaasdsa12asdsd
foobarspamasdasdasf
13234454556666
12335345asasff
sadfkajfkaskfhsdklfhjkashfjasjasdhjash123243453667786
adas434";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}