import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*(?:[A-Za-z].*\\d|\\d.*[A-Za-z]))[A-Za-z0-9]{10,50}$";
final String string = "foobarasdaasdsa12asdsd\n"
+ "foobarspamasdasdasf\n"
+ "13234454556666\n"
+ "12335345asasff\n"
+ "sadfkajfkaskfhsdklfhjkashfjasjasdhjash123243453667786\n"
+ "adas434";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}