import re
regex = re.compile(r"^(?=.*(?:[A-Za-z].*\d|\d.*[A-Za-z]))[A-Za-z0-9]{10,50}$", flags=re.MULTILINE)
test_str = ("foobarasdaasdsa12asdsd\n"
"foobarspamasdasdasf\n"
"13234454556666\n"
"12335345asasff\n"
"sadfkajfkaskfhsdklfhjkashfjasjasdhjash123243453667786\n"
"adas434")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")