re = /^(?=.*(?:[A-Za-z].*\d|\d.*[A-Za-z]))[A-Za-z0-9]{10,50}$/m
str = 'foobarasdaasdsa12asdsd
foobarspamasdasdasf
13234454556666
12335345asasff
sadfkajfkaskfhsdklfhjkashfjasjasdhjash123243453667786
adas434'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end