using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(abc\b)(.*(?:\r?\n(?!abc\b).*)*)";
string input = @"abc aaa
bbb abc ccc
abc ddd eee
fff abc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}