$re = '/(?m)^(abc\b)(.*(?:\r?\n(?!abc\b).*)*)/';
$str = 'abc aaa
bbb abc ccc
abc ddd eee
fff abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);