import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(abc\\b)(.*(?:\\r?\\n(?!abc\\b).*)*)";
final String string = "abc aaa\n"
+ "bbb abc ccc\n"
+ "abc ddd eee\n"
+ "fff abc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}