import re
regex = re.compile(r"(?m)^(abc\b)(.*(?:\r?\n(?!abc\b).*)*)")
test_str = ("abc aaa\n"
"bbb abc ccc\n"
"abc ddd eee\n"
"fff abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")