re = /(?m)^(abc\b)(.*(?:\r?\n(?!abc\b).*)*)/
str = 'abc aaa
bbb abc ccc
abc ddd eee
fff abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end