#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)(?P<Day>\d+\w*)[\s|\S](?P<Month>Jan\w*|Feb\w*|March\w*|Apr\w*|May\w*|Mei\w*|Jun\w*|Jul\w*|Aug\w*|Ogos\w&|Sep\w*|Oct\w*|Okt\w*|Nov\w*|Dec\w*|Dis\w*)"
Local $sString = "21 July" & @CRLF & _
"21st July" & @CRLF & _
"21 people" & @CRLF & _
"1 January" & @CRLF & _
"2 Jan" & @CRLF & _
"20 Mei" & @CRLF & _
"25 May" & @CRLF & _
"30 Julai" & @CRLF & _
"31 Julai" & @CRLF & _
"30 Oktober" & @CRLF & _
"21July"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")