import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Day>\\d+\\w*)[\\s|\\S](?P<Month>Jan\\w*|Feb\\w*|March\\w*|Apr\\w*|May\\w*|Mei\\w*|Jun\\w*|Jul\\w*|Aug\\w*|Ogos\\w&|Sep\\w*|Oct\\w*|Okt\\w*|Nov\\w*|Dec\\w*|Dis\\w*)";
final String string = "21 July\n"
+ "21st July\n"
+ "21 people\n"
+ "1 January\n"
+ "2 Jan\n"
+ "20 Mei\n"
+ "25 May\n"
+ "30 Julai\n"
+ "31 Julai\n"
+ "30 Oktober\n"
+ "21July";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}