const regex = new RegExp('(?P<Day>\\d+\\w*)[\\s|\\S](?P<Month>Jan\\w*|Feb\\w*|March\\w*|Apr\\w*|May\\w*|Mei\\w*|Jun\\w*|Jul\\w*|Aug\\w*|Ogos\\w&|Sep\\w*|Oct\\w*|Okt\\w*|Nov\\w*|Dec\\w*|Dis\\w*)', 'gui')
const str = `21 July
21st July
21 people
1 January
2 Jan
20 Mei
25 May
30 Julai
31 Julai
30 Oktober
21July`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}