use strict;
my $str = '21 July
21st July
21 people
1 January
2 Jan
20 Mei
25 May
30 Julai
31 Julai
30 Oktober
21July';
my $regex = qr/(?P<Day>\d+\w*)[\s|\S](?P<Month>Jan\w*|Feb\w*|March\w*|Apr\w*|May\w*|Mei\w*|Jun\w*|Jul\w*|Aug\w*|Ogos\w&|Sep\w*|Oct\w*|Okt\w*|Nov\w*|Dec\w*|Dis\w*)/uip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}