// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)(?P<Day>\d+\w*)[\s|\S](?P<Month>Jan\w*|Feb\w*|March\w*|Apr\w*|May\w*|Mei\w*|Jun\w*|Jul\w*|Aug\w*|Ogos\w&|Sep\w*|Oct\w*|Okt\w*|Nov\w*|Dec\w*|Dis\w*)").unwrap();
let string = "21 July
21st July
21 people
1 January
2 Jan
20 Mei
25 May
30 Julai
31 Julai
30 Oktober
21July";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}