import re
regex = re.compile(r"^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("hugepoopy.kst\n"
"buy@hugepoopy.kst\n"
"buy_many@hugepoopy.kst\n"
"buy@many@hugepoopy.kst\n"
"buy.many@hugepoopy.kst\n"
"hugepoopy.tst\n"
"huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst\n\n"
"khugepoopy\n"
"buy@khugepoopy\n"
"khuuugepoopy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")