#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http(s)?:\/\/.*(\d{4}).*\/(.*)"
Local $sString = "http://my-domain-1234.more-stuff.com/snowblower" & @CRLF & _
"https://my-domain-1234.more-stuff.com/snowblower" & @CRLF & _
"http://example-4321.software.com/xmlsfasfd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")