// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http(s)?:\/\/.*(\d{4}).*\/(.*)").unwrap();
let string = "http://my-domain-1234.more-stuff.com/snowblower
https://my-domain-1234.more-stuff.com/snowblower
http://example-4321.software.com/xmlsfasfd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}