using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http(s)?:\/\/.*(\d{4}).*\/(.*)";
string input = @"http://my-domain-1234.more-stuff.com/snowblower
https://my-domain-1234.more-stuff.com/snowblower
http://example-4321.software.com/xmlsfasfd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}